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Welcome to Private Contact

Encrypted Contact Data

Private Contact is a program to manage and keep secret contact data regarding 
persons, companies and institutions.
All data are saved on disk always and only in an encrypted form.
After closing them, encrypted documents can’t be opened without the right 
password.

Private Contact is the ideal software to store contact data containing reserved data 
or simply to keep contact data and be sure other apps on your Mac can’t access 
your data because data are encrypted and visible only using Private Contact with 
the correct password.
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Getting Started with Private Contact

Start to Work with Private Contact

Open a new document or use the one opened for you at startup.

It will ask for a password to protect the document
Be sure to use a password you will remember.
In case store it in your preferred Password Manager
If you don’t use one we suggest to have a look at our Password Repository.

After inserting the password to protect the document, it will be ready to accept input.

Insert a new contact pressing the add icon in the toolbar 
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or at the foot of the contact list

A first contact will be created.

Insert all the  data contacts you like.
Open the categories panel selecting 'Edit Categories…'under the 'Edit' menu
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Add and edit some labels modifying the color of the text and of the background.
Go back to the main window and add others contact and assign different categories 
to any contact selecting it from the popup menu

Use the toolbar to filter contacts using category and search key

Save your document to disk.
Close the document. Try to open it (you need to remember the password assigned 
to the document)
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Insert the correct password and press return. 
Done. 
You Created a new document filled with data, saved it encrypted and reopened it 
decrypting it using the correct password
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Private Contact Reference

Documents

Private Contact is a standard Cocoa Document based application.
You can save as many disk based documents as you like and any documents can 
contain as many contact data you like

Window Organization 

Private Contact window is divided in two part, a left part with a list of all the contacts 
categorized using categories and a right part showing the details of the selected 
contact.

When a filter criteria is in action using the category popup or the search field in the 
toolbar the left part shows only the contact passing the filter criteria. To show all the 
contact again select "Show All" from the category popup in the toolbar and void the 
content inside the search field 
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Toolbar

Private Contact uses a standard Mac Toolbar in the upper part of the window.
It acts as every standard toolbar in any Cocoa modern Mac application.
You can customize the toolbar in the standard way.
Right Click or Control-Click on the toolbar and select "Customize Toolbar..." 

Adding Data 

To add a contact select the Add icon from the toolbar or the bottom additional 
command buttons.

You can also use the + at the foot of the contact list

When created a contact is automatically put in "edit" mode.
You can start insert data immediately.
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If you are browsing data in "View" mode and need to modify it, you must switch from 
"View" mode to "Edit" mode using the buttons inside the data or in the toolbar or 
using the menu command.
In edit mode any contact can be assigned to a category using the popup menu 
inside the contact data area.

Deleting data

To delete a contact use the ‘delete’ button in the toolbar or at the bottom of the 
contact list

Editing Categories

You can have a standard list of categories you can add, remove and edit.
You can choose the color of the text and background.
At any moment you can change the category assigned to a contact from the popup 
menu inside the contact data.
When created, a new contact has its category set to default one.
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To select a category to the default, use the "Edit categories" dialog, form the Action 
Popup in the bottom command row. 

Any category shows how many contacts uses it in the ‘Contacts’ column.

A category in use by a contact can’t be removed.
To remove a category you need in advance to go to the contact using it and change 
the category in use.

Editing Labels 

You can customize the labels of the field.
In that way you can use the fields for the data you really require. 
To edit the labels choose 'Edit Labels…' under the 'Edit' menu.
After editing the labels the form (both the 'View' and the 'Edit') of Private Contact will 
display the new labels reflecting your needs and the content of the data you want to 
store.
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Note that every document has its own set of personalized labels and the labels are 
saved inside the document data fully encrypted.
So an hacker can't read even the label you chose and saved inside a document. 

You can also select to visualize an open button near any field.
Using that button you can open web pages directly in the browser or mail address 
via mail.app (opening a new mail with that address)

Browse Data 

Private Contact shows the list of all the contacts inside the document on the left and 
the detail of the selected contact on the right.
To browse the contact select the contact on the left.
You can order the contacts by category and by name selecting the column headers 
in ascending and descending orders.
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Opening URLs or emails

On the right of any field an optional button can open the content in the browser (if is 
an url) or in mail.app (if it is an email address)
This is valid both in view and in edit mode.

This button can be enabled/disabled in the edit labels panel.
The edit labels panel can be invoked form the menu or the toolbar.
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Search Data

You can select in the toolbar to search selecting which category to filter and 
additionally using a string

An additional info view will show the result of the search.

Lock document

You can select ‘Lock Document’ from the application menu or from the toolbar to 
revert the document to the locked status.
To unlock it you need to re-insert the password as if you were opening it from disk.

Address Book import

Private contact can import from the Address Book on your Mac
Simply select from the menu ‘Import from Address Book’ and a panel will open 
allowing you to select which contacts to import (checking them) or simply import all.
The selected contact will be copied inside Private Contact.
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Import from a Text File

Private Contact can import form text file in CSV (comma separated value) and TSV 
(tab separated value) format 

To import from a text file you need to have data saved inside a text file in TSV (tab 
separated value) or CSV (comma separated value)

To import use the ‘Import from text file’ command under the ‘File’ menu.

The application can auto-detect file using different encoding.
If it fails you can select from the open dialog the used file encoding

Select the file to import, Private Contact can even recognize automatically the 
format used in the file (TSV or CSV or CSV-S) regardless of the file extension.

Select in the following dialog what to import and where (in which field)

You can even browse in advance the entire content you are importing, to better 
decide, before importing it.

Private Contact has one of the best import functionality available for Mac.

Export to a Text File

To export the data inside a document select “Export to Text File” from the “File” 
menu.
Private Contact will present a standard file dialog to define which fields to export and 
in which specific order:
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After that you will be asked to select a destination where to save and the format.
You can choose between:
CSV (comma separated value)
TSV (tab separated value)
Html table
Html table embedded inside a web page
Custom where you can insert the detailed custom tags you want to use to generate 
a data export

Save Data 
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Saving a Private Contact files is similar to saving in any document based Cocoa 
application.
The first time you save a new document, Private Contact ask you to set a password 
to protect it, after that, you never will be asked to insert again the password to save 
the document.
You will need to remember it only to open the document.

Open Data 

To open a document form disk select it from the "Open" dialog.
You will be asked the password to decrypt it.
Note that the document is not just locked but entirely encrypted.
There is no way to read the data inside your document without the password used 
to save it.
Even an expert hacker can do noting with your document file if he doesn't know the 
password.

Changing Password

At any moment the password protecting the document can be changed selecting 
'Password…' form the 'File' menu. If a password was already set you will be asked 
to confirm the old one and to insert the new one. Remember the password or your 
data will be lost.
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Encryption

When you save a document, the document is always saved as encrypted, Private 
Contact do not save in plain format.
This to avoid saving in an unprotected mode.
This is because you can't save without specify a password.
All data inside your contacts are encrypted, also the list of categories you specified 
for the document (it can contains reserved words). 
Algorithm used for encryption is AES-256 , a very strong encryption method, this 
offer a high security for your data.
It offer compatibility with document saved with older release using the Blowfish 
algorithm. It will read and decrypt them using Blowfish and then when  re-saved 
AES-256 will be used.

You are informed that loosing your password used to protect the document is equal 
to loosing all the data inside the document.
Use our Password Repository or a similar program to save the different passwords 
you use in your life or you can be in trouble one day specially if you need to 
remember a password is a long time you don't use!

Don’t forget the Password

Without the password used to save the document, the document is just a bunch of 
not readable data.
If you loose the password the document can not be decrypted.
Even we, the creator of the application can do nothing to help you to recover your 
document if you loose your password.
We suggest, to save all your password using our application Password Repository 
to avoid loosing your precious passwords.
Password Repository is available for download at our site.
You can access our site from Private Contact using the ‘Web Site’ command under 
the ‘Help’ menu.

The macOS standard features

Private Contact adopts and makes use of the latest Apple technologies

They are used in the standard Apple way, so nothing new to learn if you already 
know how  to use them.

• Resume – the app will reopen at the point and state the user left it included 
opened documents and unsaved one

• Auto save – the app saves using the macOS autosave functionality 

• Versions – the user can look at previous versions of documents and restore to any 
earlier version (just select Revert to Saved from the menu or the down arrow at the 
right of the title window, it appears only if you move the cursor over)
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• Full Screen - the user can switch at any time to full screen  using the native 
macOS full screen mode and commands (use the upper right icon in the window to 
go full screen and bang the mouse in the upper part of the screen to re-obtain the 
menu and eventually clicking the standard icon to exit the full screen mode)

Dark Appearance Mode

Private Contact is fully compatible with Dark Appearance Mode and Light 
Appearance Mode on any macOS release it can run on.
You can switch at any time from one mode to another

Preferences

General

Specify the action to do at startup
• New Document: creates a new document at startup
• File browser: opens the dialog to select a Private Contact document from disk to 

launch 
• None: performs nothing at startup
• Open Selected Document: allows to select a document and have it launched 

automatically at startup, this is a standard way to operate in case you use just a 
single document as the main repository of your notes or use often the same 
document.

To select a document you have 3 way: 
• Pressing the select from disk button and select it from the open dialog that will 

follow
• Dragging it from the finder or dragging it using the proxy icon (the icon in an 

opened document in the title bar)
• Editing it in the edit field by keyword (the hard way)

Private Contact User Guide  © 2006-2025 Ecleti - Roberto Panetta page 18



At any successive relaunch Private Contact will execute the option selected.
The additional two buttons at the foot of the edit field let you:
• Show in the finder the selected file
• Test open the selected file as it will be done at the next application launch

Font

Font settings:
• Font used in a new opened document
• Font used to display the public note

Advanced

Auto Lock:
With Auto lock you can choose to have any document locking itself automatically 
after a specified interval the application is in background.
Very useful if you switch to another application and you forget Private Contact in 
background with your data exposed.
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Update

* Update section is not available in the App Store Release  
(if you purchased via the App Store, to obtain the updates use the App Store 
internal update function)

Private Contact can inform you if an update is available.
We suggest to leave the ‘Notify about available update’ always on

When you check if an update is available, the application ping the Tension Software 
server and receive an answer about the last release available, the application can in 
that way know if its obsolete or not.
In case the application will ask you if you like to download an upgrade.

If you download the upgrade, you need to install it.
A common error is to download an upgrade and install it maintaining the old 
application somewhere on the hard disk.
Then using to open the documents sometime the old application and sometime the 
new one. This cause some problems*. To avoid it simply install your application in 
the place dedicated to it, the Application folder. When you install an update on the 
standard Application folder, the system will ask if you want to replace the old one 
with the new, answering yes will install the new one replacing the old.

*If the application says the document you are trying to open was created with a newer 
version of the application, probably you have two different release of the application on your 
Hard Disk and you are trying to open a document with the older version after having 
modified the document with the new one. When you receive a similar message open the 
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about box inside the application and see if you are running the last release. In case 
download it, install it and USE it!

Help

Private Contact provides a PDF user guide under the ‘Help’ menu.

Support
 
You can also obtain support using the ‘Support Email...’ command. An email will be 
prepared using your email client with the correct address to send to.
Yes, we answer to your emails.

About Tension Software and Ecleti

All the software asset by Tension Software is now under Ecleti 
New company name but still the same owner and main developer (Roberto Panetta)
So for the users nothing changes. We provide the same software and the services. 
All the user licenses are valid and assistance is provided as before to all our users.
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